If you do not receive your verification email after registering, please check your spam folder. You can also get in contact with us via other methods.
Если вы не получили письмо c подтверждением регистрации, пожалуйста, проверьте папку спам. В случае отсутствия письма и там напишите нам другим способом.

Visual glitches.

Community-based support for our public releases.
Общественная поддержка для публичных релизов.
Bernkastel77
Posts: 34
Joined: 12 Sep 2017, 17:27
Gender: Male

Visual glitches.

Post by Bernkastel77 » 12 Sep 2017, 17:34

Hi vit9696.

Thanks for the fast responses.
It's done. The topic was created.

Here my GPU: http://imgur.com/a/O0Drm

Can you help me? Hahaha.

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Visual glitches.

Post by vit9696 » 12 Sep 2017, 17:50

Hi,

I think I can. From what I can see is that you have an ASUS laptop with AMD and Intel GPUs installed. I think that due to some weird reason Intel GPU is used instead of AMD.

My first suggestion will be to try to force AMD GPU. There is a KB article on AMD website, that explains how to specify the preferred GPU for an app:
https://community.amd.com/docs/DOC-1581

I think I won't be able to explain it better, and it might be a very good idea to try it first.
Also, you probably should undo all the changes you previously made (e.g. ons.cfg changes).

Let me know if and where it fails, in this case we will think of updating the drivers. Could you also specify the exact laptop model?

Bernkastel77
Posts: 34
Joined: 12 Sep 2017, 17:27
Gender: Male

Re: Visual glitches.

Post by Bernkastel77 » 12 Sep 2017, 18:48

My PC is desktop, not laptop. It was built. I think it's don't have a specific model.
Also, i don't have this version of AMD Radeon settings, so I trying this with AMD CCC, i found this option (http://imgur.com/a/jSTRj) which I believe is the same.
Maybe if I put onscripter here shall this work? I'll try.

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Visual glitches.

Post by vit9696 » 12 Sep 2017, 18:55

Ah, if it is a desktop, then it is likely that the drivers are just outdated (according to the screenshot they are from 2013).
Just install these ones: http://support.amd.com/en-us/download/d ... ows+7+-+64 and retry.

If it does not help, it might indeed be worth checking AMD CCC preferences, but I think that should not be needed.

Bernkastel77
Posts: 34
Joined: 12 Sep 2017, 17:27
Gender: Male

Re: Visual glitches.

Post by Bernkastel77 » 12 Sep 2017, 19:04

To be honest, when I tried solve this by my own, I tried install this "updater", but, for some reason, when the installing proceeds my screen turns entirely black (lol). So I restart my computer and nothing change.

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Visual glitches.

Post by vit9696 » 12 Sep 2017, 19:16

In this case you will firstly have to properly uninstall the existing installation, reboot, and install again (pick 17.9.1 I guess?). Here is a relevant KB article:
http://support.amd.com/en-us/kb-article ... ivers.aspx

It is often good to avoid performing a direct upgrade and use a clean install due to clumsy situations like this.

(Don't worry, even when you remove the drivers, there will still be software driver that does not provide hardware acceleration, so you will be able to boot into Windows)

Bernkastel77
Posts: 34
Joined: 12 Sep 2017, 17:27
Gender: Male

Re: Visual glitches.

Post by Bernkastel77 » 13 Sep 2017, 02:08

Hi. Sorry for being late. I had to attend my college.
So now, i'm finally in home.
Well, first of all i'll make it clear: I tried what you just did say to do.
And guess what...? Didn't work.
Again, my screen became entirely black... curiously, this time the installation actually had been finished, but when I rebooted the system, before the windows start, my monitor suffered a blackout.
I searched in google and I found other people which had this trouble in the past. Apparently this is a typical AMD issue.
Buuuut, I was reading the release notes of the 17.9.1 ReLive and then I realized that is a beta version. Maybe, because of this, this fucking trouble occurs.

Now, my last try will be in the 17.7.2, the previous version.
If it doesn't work... well, we'll have to come up with another solution.

Btw, hope you're still awake. Hahahahaha.

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Visual glitches.

Post by vit9696 » 13 Sep 2017, 02:28

Welcome back, you caught me right before heading to bed, so you should probably expect the next reply later in the morning.
I checked the forums, and it indeed seems to be a popular bug introduced in at least 17.4.x branch and still unfixed for several configurations. Goddamn AMD :/

According to https://community.amd.com/thread/217162 17.3.3 was the last one that worked for the topic starter, so I think it is worth trying: http://support.amd.com/en-us/download/d ... rev=17.3.3

If it does not, it might be worth trying a few more older versions, after all anything newer than 13.200.0 you have should be an improvement.

If you get bored in the meanwhile, after some googling I additionally discovered the following suggestions, which might actually be worth trying:
1. Try power off / Start instead of reboot
2. Check if it is only the backlight not working, and not the driver, for that attempt to create/edit the following parameters in windows registry: http://forum.radeon.ru/viewtopic.php?p=887206#p887206, actually since you have a desktop you would probably want 0s instead of 1s

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Visual glitches.

Post by vit9696 » 13 Sep 2017, 11:35

There is something else I want to tell you. We discussed what else this could be other than GPU drivers, and… given that your friend had exactly the same issue with completely different hardware, Giza came up with a suggestion that you might have your game files corrupted. There could be various reasons for that, including:
— Failed extraction (Older versions of certain archivers could silently extract incorrectly O_o, did you use the latest version of 7-zip http://www.7-zip.org?)
— HDD fault

This hardly goes in line with:
My game has several visual glitches and errors, for example, when I try open the config in the title screen, and then I go back to menu, the screen turns entirely black.
But now that we reexamined the screenshots, all of them have missing textures and not even one corrupted/distorted image.
Could you please verify a few files, whether they open, their sizes, and maybe hashes. For example:

Code: Select all

backgrounds/mlib_1b_bg.png, 93 392 bytes, md5 e9f080b0e1aa565ec83ad1deb0c352f8
backgrounds/mlib_1b.png, 3 748 405 bytes, md5 c5c9ce23fd4c328d54c1c8a14b399bf8
sprites/kin/1/kin_a11_defo1.png, 534 633 bytes, md5 396ee45f91174871a86dd12a0d67a081
Firstly it is worth trying to open these files, since they are all plain png images, they should open with any image viewer with no issue. Secondly, you could check the size in file properties. Then, to calculate md5 hashes you could use http://implbits.com/products/hashtab/. If you have any issue or have doubts that everything went right, you may just upload these files here.

Bernkastel77
Posts: 34
Joined: 12 Sep 2017, 17:27
Gender: Male

Re: Visual glitches.

Post by Bernkastel77 » 13 Sep 2017, 19:15

First of all, well, I must say that a big fucking misunderstanding occurred between me, you and AMD hahahaha.
Actually, my GPU isn't a real AMD, but a Gigabyte with AMD chipsets.
The specific model is GVR726X, and apparently there is no driver update for this version. If you access the gigabyte website, the only driver you will find will be my current one. So you're right, maybe it has nothing to do with GPU. And no, I didn't use 7zip, I used the old WinRar.

I'll check the files.

Post Reply