If you do not receive your verification email after registering, please check your spam folder. You can also get in contact with us via other methods.
Если вы не получили письмо c подтверждением регистрации, пожалуйста, проверьте папку спам. В случае отсутствия письма и там напишите нам другим способом.

Controllers not rumble; Automode speed issue

Community-based support for our public releases.
Общественная поддержка для публичных релизов.
YNagato
Posts: 178
Joined: 08 Jul 2016, 21:35
Gender: Male

Controllers not rumble; Automode speed issue

Post by YNagato » 12 Jul 2016, 03:28

Hi,

A few days into the wonderful game greatly improved in this Project, Using the B-release (Episode 3), I came across two issues and wonder if I could get more insights here:

1. I tried both my Dual Shock 3 and Xbox One controller on both Windows 8.1 and 10. Both work more or less the same with the gameplay. No issues except that neither of them get any rumbling even though I already the rumbling is set to maximum strength. I also tried x360ce.exe but got the same result. The Dual Shock 3 has worked fine with my PS3. And the Xbox One controller also functions well with other PC games. Does the rumbling function fully operate in the latest B-release?

2. I also notice that while the automode speed setting can slow down the speed at which one non-dialogue passage jumps to another, but cannot really delay the dialogue. Regardless of the automode speed setting, the dialogue would almost instantly shift to the next passage whenever it comes to the last line. Could you consider introduce some delay between the passages of the dialogue depending on the automode speed setting? I myself have no problem with the current speed, but when I introduce the game to my family, they said they wished the dialogue could slow down a bit so that they could capture the last line every time...

Many, many thanks again!
Last edited by YNagato on 12 Jul 2016, 09:14, edited 1 time in total.

Knox
Администратор
Posts: 194
Joined: 24 Feb 2015, 23:11
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by Knox » 12 Jul 2016, 06:34

YNagato wrote:1. I tried both my Dual Shock 3 and Xbox One controller on both Windows 8.1 and 10. Both work more or less the same with the gameplay. No issues except that neither of them get any rumbling even though I already the rumbling is set to maximum strength. I also tried x360ce.exe but got the same result. The Dual Shock 3 has worked fine with my PS3. And the Xbox One controller also functions well with other PC games. Does the rumbling function fully operate in the latest B-release?
It does, but it doesn't surprise me to hear that it works spottily. We don't have a lot of controllers around to test.

I have not tried x360ce -- I use ScpServer for Dual Shock 3, which seems to work fine. The latest version looks to be here -- maybe try this out instead?
YNagato wrote:2. I also notice that while the automode speed setting can slow down the speed at which one non-dialogue passage jumps to another, but can really delay the dialogue. Regardless of the automode speed setting, the dialogue would almost instantly shift to the next passage whenever it comes to the last line. Could you consider introduce some delay between the passages of the dialogue depending on the automode speed setting? I myself have no problem with the current speed, but when I introduce the game to my family, they said they wished the dialogue could slow down a bit so that they could capture the last line every time...
You could try an option like this in ons.cfg:

Code: Select all

voicedelay-time=3000
It is meant to add the given time (in ms) after every voiced dialogue file in automode, but as I test it now, it seems to be working kind of inconsistently. The implementation might be broken... I will have a look tomorrow.
Let me know if you meant something completely different to this :D

YNagato
Posts: 178
Joined: 08 Jul 2016, 21:35
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by YNagato » 12 Jul 2016, 09:05

Many thanks for your prompt reply. I actually used the same ScpServer to set up the Dual Shock 3. Only after it didn't produce the rumbling effect of the game did I try the X360ce.exe, to make the controller behave like a Xbox 360 controller. Either way, there is no rumbling.

The voicedelay setting is very useful. Thanks for pointing it out and offering to look into it further. What I meant is close but not exactly the same. After experimenting with it a bit, I found that since voicedelay introduces gaps between voice files, it might interrupt the flow of sentences, especially when a voice file contains only a couple of words. If the delay is introduced not at the end of each voice file but just at the end of one paragraph defined by each textbox, that would be even better.

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by vit9696 » 12 Jul 2016, 14:01

Ah, that's what you meant. Actually, I may imagine discussing that. Will definitely be low-pri if we agree on implementing it, but given that it is not going to be hard to implemnt, there is a good chance for such a feature to appear.

As for DS3, it is quite strange. Mostly because Knox would have eaten me if I left his precious windows without the vibrations. I guess your gamepad is pretty much the original one, so it should work. Last time I tried it on Windows it only workd in xinput mode for me. Let me try some thoughts that could be of some help.
— Are you sure your chosen mode is xinput? (it is easy to check by adding use-console to ons.cfg and then seeing how it names your gamepad)
— For wired DS3 and SteamPad connections we also support direct calls, which means that if you connect DS3 over USB, and it shoukd rumble regardless of the driver. Did you try that instead of bluetooth?
— I think Knox uses an old version of ScpServer (1.2.0.160, if I remember correctly), might be worth trying it? I think he has no bluetooth support on his PC as well.
— As for myself I used MotioninJoy with BetterDS3 for a test. I think in xinput mode it worked for me even over the bluetooth. Might be worth trying it as a last option?

In any case, Knox should have more experience, and if none of the above works we should still be able to find a solution sooner or later.

YNagato
Posts: 178
Joined: 08 Jul 2016, 21:35
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by YNagato » 12 Jul 2016, 23:04

I always use the USB connection. I don't remember I deliberately chose the Xinput Mode. I just assumed it's Xinput by default. I can't find the option in ScpServer. Did I miss something?

I added "use-console" to the configuration file as instructed, and got the following diagnosis:

"DS3Controller::Initialising DualShock 3
Initialising joystick(0 -> 0): XInput Controller #1, haptic: maybe supported"

So does it mean it recognizes my controller in Xinput mode? I attach the complete copy of the diagnosis below. (Also wondering why so many usb errors at the beginning.)

I will try out MotioninJoy with BetterDS3 for the last resort after hearing your interpretation of this diagnosis. Thanks!


Adding path: C:\Users\lingh\Downloads\GG\Umineko HD\
Adding path: .
Adding path: ..
Adding path: C:\Users\lingh\Downloads\GG\Umineko HD\;.\;..\
Script found: C:\Users\lingh\Downloads\GG\Umineko HD\en.file
Failed to use the iCloud storage.
Falling back to Application Support folder.
Adding path: C:\ProgramData\ONScripter-RU\UminekoPS3ficationEn\
Adding path: C:\Users\lingh\Downloads\GG\Umineko HD\;.\;..\
libusb: error [init_device] device '\\.\USB#VID_03F0&PID_3817&MI_01#7&1AECE864&7&0001' is no longer connected!
libusb: warning [windows_get_device_list] could not retrieve port number for device '\\.\USB#VID_045E&PID_028E&IG_00#2&9C6DEB5&0&00', skipping: [13] The data is invalid.
libusb: error [init_device] program assertion failed: device address collision with root hub
libusb: warning [windows_get_device_list] '\\.\USB#VID_045E&PID_028E#0000001' was only detected in late pass (newly connected device?) - ignoring
libusb: error [init_device] device '\\.\USB#VID_03F0&PID_3817&MI_01#7&1AECE864&7&0001' is no longer connected!
libusb: warning [windows_get_device_list] could not retrieve port number for device '\\.\USB#VID_045E&PID_028E&IG_00#2&9C6DEB5&0&00', skipping: [13] The data is invalid.
libusb: error [init_device] program assertion failed: device address collision with root hub
libusb: warning [windows_get_device_list] '\\.\USB#VID_045E&PID_028E#0000001' was only detected in late pass (newly connected device?) - ignoring
libusb: error [init_device] device '\\.\USB#VID_03F0&PID_3817&MI_01#7&1AECE864&7&0001' is no longer connected!
libusb: warning [windows_get_device_list] could not retrieve port number for device '\\.\USB#VID_045E&PID_028E&IG_00#2&9C6DEB5&0&00', skipping: [13] The data is invalid.
libusb: error [init_device] program assertion failed: device address collision with root hub
libusb: warning [windows_get_device_list] '\\.\USB#VID_045E&PID_028E#0000001' was only detected in late pass (newly connected device?) - ignoring
DS3Controller::Initialising DualShock 3
Initialising joystick(0 -> 0): XInput Controller #1, haptic: maybe supported
filename 'breakup.frag', extension 'frag'.
filename 'breakup-cellforms.png', extension 'png'.
filename 'blendByMask.frag', extension 'frag'.
filename 'colorModification.frag', extension 'frag'.
filename 'mergeAlpha.frag', extension 'frag'.
filename 'multiplyAlpha.frag', extension 'frag'.
filename 'glyphGradient.frag', extension 'frag'.
filename 'effectWarp.frag', extension 'frag'.
filename 'effectWhirl.frag', extension 'frag'.
filename 'effectTrvswave.frag', extension 'frag'.
filename 'cropByMask.frag', extension 'frag'.
filename 'blurH.frag', extension 'frag'.
filename 'blurV.frag', extension 'frag'.
filename 'textFade.frag', extension 'frag'.
filename 'pixelate.frag', extension 'frag'.
Maximum texture size is 16384
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'ass.dll'.
Setup layer effect for 'video.dll'.
setup a sprite for layer 10
libass [4]: Shaper: FriBidi 0.19.7 (SIMPLE) HarfBuzz-ng 1.2.4 (COMPLEX)
libass [4]: Added subtitle file: 'C:\Users\lingh\Downloads\GG\Umineko HD\video\sub\eng.ass' (3 styles, 13 events)
Detected framerate is 29.97, vfr 0, corrupted 0
libass [2]: fontselect: Using default font: (Arno Pro, 400, 0) -> C:\Users\lingh\Downloads\GG\Umineko HD\fonts/font1.otf, 0, (none)
libass [4]: fontselect: (Arno Pro, 400, 0) -> C:\Users\lingh\Downloads\GG\Umineko HD\fonts/font1.otf, 0, (none)
***[Warning] I/O Issue at line 191436 (*title_loading:70) - can't find file [graphics\menu_en\title\chiru\title1_text_ep5.png] ***
***[Warning] I/O Issue at line 191437 (*title_loading:71) - can't find file [graphics\menu_en\title\chiru\title1_text_ep6.png] ***
***[Warning] I/O Issue at line 191438 (*title_loading:72) - can't find file [graphics\menu_en\title\chiru\title1_text_ep7.png] ***
***[Warning] I/O Issue at line 191439 (*title_loading:73) - can't find file [graphics\menu_en\title\chiru\title1_text_ep8.png] ***

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by vit9696 » 12 Jul 2016, 23:52

The log does look healthy, and your controller is indeed detected as an Xinput controller.
According to "haptic maybe supported" line it seems that rumble may well work, this is also the correct behaviour…

libusb errors are probably ok, although I wonder what happens if you reconnect the gamepad right after starting the game.
Also, could you show the log after rumbling a little? Go to preferences and change rumble power, it should be reflected on the device. I wonder what error are we going to get.

Also, is there a chance of a driver conflict? I mean, did you try anything before that?
Also, is Win 10 your only Windows? Maybe something broke in it…

YNagato
Posts: 178
Joined: 08 Jul 2016, 21:35
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by YNagato » 13 Jul 2016, 01:36

Finally I got rumbling! I have to either plug in the controller or reconnect it as you suggest only AFTER starting the game. Then it rumbles well. It won't rumble at all if it is connected beforehand. So it still has to do with the dubious libusb errors?

By the way, no error log is generated even if it doesn't rumble in the configuration of the rumbling strength. Again, it rumbles a little in that context when I connect the gamepad after the game starts.

As for the possibility of driver conflicts, I did install the Xbox One controller first before I tried the DualShock 3. But Windows 10 always has the Xbox One controller driver ready. I just plugged it in only and it automatically finished the installation.

Another thing I tried is X360ce.exe, after both X1 controller and DS3 failed to rumble. But I already deleted the X360ce files.

User avatar
vit9696
Администратор
Posts: 1530
Joined: 24 Feb 2015, 00:48
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by vit9696 » 13 Jul 2016, 01:59

Wow, that's something. Glad that we got this far.

I have just checked the source code, and it seems that the rumble errors are only displayed after you add:

Code: Select all

debug
line to ons.cfg, could you retry please with the gamepad initially plugged in and with a reconnect (i.e. not working and working rumble). I'd like to have a complete log and see what it actually utilises in either case. They might be long, so use a spoiler tag ^^;

I expect the issue to be libusb sending the command improperly but assuming it was ok. As a result we get rumble success and do not try the native API. Perhaps a better approach will be to propioritise the API over direct libusb calls. We will try to verify the idea but might still need more of help. Thanks for patience.

By the way, Knox added final-voicedelay-time ons.cfg option which actually adds an additional delay at the end of every voiced dialogue overriding the last delay set by voicedelay-time option. This will be included and tested in the next alpha build (close to the weekends, I think). Unfortunately our alpha is not going to move to beta right away, yet we have to polish things, and just sending you the updated engine won't work either due to incompatible script changes. Perhaps, you would like to have an access to our bleeding edge updates?

YNagato
Posts: 178
Joined: 08 Jul 2016, 21:35
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by YNagato » 13 Jul 2016, 02:51

I added "debug" to the cfg and got the following log. Please notice that when I plug in the DS3 before the game starts, the no-rumbling error doesn't show in the log. But when I reconnect the DS3 in the middle of the game, the rumbling functions well, but it ironically starts to generate the following error log:

"libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use."

It's somewhat counterintuitive... So whenever you see this log, it means it rumbles well actually!

P.S.: Another scenario is: if I plug in the DS3 only after the game starts rather than un-plug and re-plug it, then no error log is generated when it rumbles.

Actually without adding "debug" to cfg, I have seen these patterns before in the past logs. So the debug doesn't show me any new revelation of the no-rumbling error. Strange..

And many thanks for adding the final-voicedelay-time function! Yes, I would love to access the alpha testing version!
[+] Spoiler
Adding path: C:\Users\lingh\Downloads\GG\Umineko HD\
Adding path: .
Adding path: ..
Adding path: C:\Users\lingh\Downloads\GG\Umineko HD\;.\;..\
Script found: C:\Users\lingh\Downloads\GG\Umineko HD\en.file
humanpos: 480,960,1440; underline: 1079
Failed to use the iCloud storage.
Falling back to Application Support folder.
Adding path: C:\ProgramData\ONScripter-RU\UminekoPS3ficationEn\
Adding path: C:\Users\lingh\Downloads\GG\Umineko HD\;.\;..\
libusb: error [init_device] device '\\.\USB#VID_03F0&PID_3817&MI_01#7&1AECE864&7&0001' is no longer connected!
libusb: warning [windows_get_device_list] could not retrieve port number for device '\\.\USB#VID_045E&PID_028E&IG_00#2&9C6DEB5&0&00', skipping: [13] The data is invalid.
libusb: error [init_device] program assertion failed: device address collision with root hub
libusb: warning [windows_get_device_list] '\\.\USB#VID_045E&PID_028E#0000001' was only detected in late pass (newly connected device?) - ignoring
libusb: error [init_device] device '\\.\USB#VID_03F0&PID_3817&MI_01#7&1AECE864&7&0001' is no longer connected!
libusb: warning [windows_get_device_list] could not retrieve port number for device '\\.\USB#VID_045E&PID_028E&IG_00#2&9C6DEB5&0&00', skipping: [13] The data is invalid.
libusb: error [init_device] program assertion failed: device address collision with root hub
libusb: warning [windows_get_device_list] '\\.\USB#VID_045E&PID_028E#0000001' was only detected in late pass (newly connected device?) - ignoring
libusb: error [init_device] device '\\.\USB#VID_03F0&PID_3817&MI_01#7&1AECE864&7&0001' is no longer connected!
libusb: warning [windows_get_device_list] could not retrieve port number for device '\\.\USB#VID_045E&PID_028E&IG_00#2&9C6DEB5&0&00', skipping: [13] The data is invalid.
libusb: error [init_device] program assertion failed: device address collision with root hub
libusb: warning [windows_get_device_list] '\\.\USB#VID_045E&PID_028E#0000001' was only detected in late pass (newly connected device?) - ignoring
DS3Controller::Initialising DualShock 3
Initialising joystick(0 -> 0): XInput Controller #1, haptic: maybe supported
GUID: 0x78, 0x69, 0x6E, 0x70, 0x75, 0x74, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
filename 'breakup.frag', extension 'frag'.
filename 'breakup-cellforms.png', extension 'png'.
filename 'blendByMask.frag', extension 'frag'.
filename 'colorModification.frag', extension 'frag'.
filename 'mergeAlpha.frag', extension 'frag'.
filename 'multiplyAlpha.frag', extension 'frag'.
filename 'glyphGradient.frag', extension 'frag'.
filename 'effectWarp.frag', extension 'frag'.
filename 'effectWhirl.frag', extension 'frag'.
filename 'effectTrvswave.frag', extension 'frag'.
filename 'cropByMask.frag', extension 'frag'.
filename 'blurH.frag', extension 'frag'.
filename 'blurV.frag', extension 'frag'.
filename 'textFade.frag', extension 'frag'.
filename 'pixelate.frag', extension 'frag'.
Maximum texture size is 16384
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'fall.dll'.
Setup layer effect for 'ass.dll'.
Setup layer effect for 'video.dll'.
Gamepad event, button: 1
Gamepad event, button: 1
***[Warning] I/O Issue at line 191436 (*title_loading:70) - can't find file [graphics\menu_en\title\chiru\title1_text_ep5.png] ***
***[Warning] I/O Issue at line 191437 (*title_loading:71) - can't find file [graphics\menu_en\title\chiru\title1_text_ep6.png] ***
***[Warning] I/O Issue at line 191438 (*title_loading:72) - can't find file [graphics\menu_en\title\chiru\title1_text_ep7.png] ***
***[Warning] I/O Issue at line 191439 (*title_loading:73) - can't find file [graphics\menu_en\title\chiru\title1_text_ep8.png] ***
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 0
Gamepad event, button: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
***[Warning] I/O Issue at line 201732 (*settings_elems:6) - can't find file [graphics\menu_en\config\gamepad_buttons.png] ***
Gamepad event, hat move: 2
Gamepad event, hat move: 0
Gamepad event, hat move: 2
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, button: 0
Gamepad event, button: 0
***[Warning] I/O Issue at line 191436 (*title_loading:70) - can't find file [graphics\menu_en\title\chiru\title1_text_ep5.png] ***
***[Warning] I/O Issue at line 191437 (*title_loading:71) - can't find file [graphics\menu_en\title\chiru\title1_text_ep6.png] ***
***[Warning] I/O Issue at line 191438 (*title_loading:72) - can't find file [graphics\menu_en\title\chiru\title1_text_ep7.png] ***
***[Warning] I/O Issue at line 191439 (*title_loading:73) - can't find file [graphics\menu_en\title\chiru\title1_text_ep8.png] ***
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, hat move: 4
Gamepad event, hat move: 0
Gamepad event, hat move: 1
Gamepad event, hat move: 0
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
libusb: error [windows_transfer_callback] detected I/O error 170: [170] The requested resource is in use.
DS3Controller::Command error -1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1
Gamepad event, button: 1

Knox
Администратор
Posts: 194
Joined: 24 Feb 2015, 23:11
Gender: Male

Re: Controllers not rumble; Automode speed issue

Post by Knox » 13 Jul 2016, 03:09

OK, I think we've got an idea of how to make rumbling more reliable now. Will give it a try.

I added you to private alpha, but the changes for this and final-voicedelay-time are not in there yet, so please wait for the next update :)

Locked